Keyframe Animation for SketchUp

User Guide
Keyframe Animation 2.0

This user guide provides detailed documentation for the newest release of Keyframe Animation, version 2.0. There is also a user guide for the previous version 1.9.

Toolbar Overview

Keyframe Animation has the main features conveniently located on the toolbar to facilitate your workflow.

Toolbar and menu
Play ButtonPlay Button
Toggles the Object Animation on and off.
Record ButtonRecord Button
Saves the position data of objects on the current scene.
Disabled if there are no scenes.
Erase ButtonErase Button
Deletes the position data of all selected objects on every scene.
Disabled if no objects are selected.
Select ButtonSelect Button
Selects all the objects that have position data saved on the current scene.
Disabled if there are no scenes.
Time Settings ButtonTime Settings Button
Toggles the display of the Scene Time Settings window.
The Scene Time Settings window lets you set the transition time and delay time for each scene.
Export Video ButtonExport Video Button
Exports the animation to a video directly from the keyframe model.
Disabled unless there are at least two scenes.
User Guide ButtonHelp Button
Opens up the User Guide (the page you are viewing now) in your browser.

Menu Overview

The menu is at Plugins > Keyframe Animation, or Extensions > Keyframe Animation, depending on your version SketchUp. All the features accessible from the toolbar are also accesible from the menu.

Toolbar and menu
Show Toolbar
Toggles the toolbar visibility.
Play ButtonAnimate Objects
Same as clicking the Play Button.
Record ButtonRecord Objects
Same as clicking the Record Button.
Erase ButtonErase Objects
Same as clicking the Erase Button.
Select ButtonSelect Objects
Same as clicking the Select Button.
Time Settings ButtonScene Time Settings...
Same as clicking the Time Settings Button.
Export Video ButtonExport Animation > Standard Video...
Same as clicking the Export Video Button.
Exports the animation to a video with a standard frame size and frame rate.
Export Animation > Custom Video...
Exports the animation to a video with a custom frame size up to 3840 x 2160 pixels, and frame rate up to 60 fps.
Export Animation > Image Sequence...
Exports the individual frames of the animation as a sequence of .jpg, .png, .tif, or .bmp images.
License Info...
Opens a window to display your license status or free trial status.
Register a license or remove a license from this computer.
User Guide ButtonUser Guide
Same as clicking the Help Button.
Download Page
Opens the Keyframe Animation Download page in your browser.
Purchase Page
Opens the Keyframe Animation Purchase page in your browser.

Creating an Animation

Step 1 - Group Geometry

Entity Info Dialog

Convert any geometry that you want to animate into groups or components. Loose geometry can not be animated.

To check the type of something, select it, right-click, and choose Entity Info from the pop-up menu.   (right-click > Entity Info)

It doesn't make any difference, for animation purposes, whether something is a group or a component. So, we will refer to them generically as objects.

Step 2 - Add Scenes

Add some scenes. You can use the Scenes Manager for this (Window > Scenes).

Each scene is essentially a keyframe. You can add more later, delete them, or change the order. To run an animation in reverse, just reverse the order of the scenes.

SketchUp will animate the properties saved with a scene. Keyframe Animation will animate the objects that are recorded on a scene. Keyframe Animation 2.0 is compatible with all the scene properties:

new iconNew in version 2.0
There are no more restrictions on the type of camera animated. You can combine the object animation with SketchUp's animation of the Parallel Projection camera, the Perspective camera, or even the perspective camera Field Of View, and export it all to a video.
tip iconTip: Camera Location
If you are creating an animation where the camera does not move, leave the Camera Location box on each scene unchecked. This way, if you want to change the perspective you view the animation from, you can change it on-the-fly, for all the scenes at once, without having to update the Camera Location property on each scene.
tip iconTip: Axes Location
The Axes Location scene property is kind of irrelevant for the purposes of this plugin because when an animation is exported, the axes are not displayed.

Step 3 - Select a Scene

Select the first scene by clicking on the scene tab. The tab becomes highlighted.

The scene with a highlighted tab is referred to as the current scene.

You can change which scene is the current one by clicking on different tabs, or by double-clicking on the scene name in the Scenes Manager.

Step 4 - Position Objects

Now use the Move Tool , the Rotation Tool , or the Scale Tool , to position and/or resize the objects on the current scene.

Step 5 - Record Objects

Click the Record Button Record Button on the toolbar to save the position data of objects on the current scene. It doesn't make any difference whether the Play button is toggled on or off. A bell will ring, and the objects that were recorded will remain selected afterward, so you can see which ones they are. A plop sound indicates that no objects were recorded.

The record feature works slightly different in version 2.0. If any objects are selected when you click the Record button, then only those objects will be recorded. This approach gives you the most control.

If nothing is selected when you click Record, then all moving objects (i.e. objects that have position data saved for any scene, not just the current one) will be recorded. This approach saves time.

Re-recording an object updates its position data. To revise an animation, simply move the objects to new positions and re-record.

new iconNew in version 2.0
There is a new Select Button Select Button on the toolbar. It selects all objects that have position data saved on the current scene. Then, with them selected, you can record them all in one click. It is also a quick way to check if an object has position data saved on a scene or not.

The Erase Button deletes the position data of all selected objects on every scene. It is useful if you want to make a moving object stationary again.

tip iconTip: Copying objects
If you copy an object (e.g. Move + Ctrl), that copies the position data too. So, you probably want to click the Erase button to delete it. Otherwise, the copied object will move to the same position as the original object during the animation.
tip iconTip: Scene Names
The position data is tied to the scene names. So, if you change them, then you will need to re-record the objects on the scenes with new names. You can make the animation loop back to the starting scene by naming the last scene the same as the first.

Step 6 - Repeat for each Scene

That is the basic workflow. Just repeat steps 3, 4, and 5 for each scene.

Note that Rotations are interpolated through the smallest angle between the object's orientation on one scene and the next. So, the angle will always be less than or equal to 180 degrees. If the angle is exactly 180 degrees, the direction is ambiguous, so the object could rotate either way.

Rotations and translations can not be combined, in general. However, if the translation is parallel to the axis of rotation, then Keyframe Animation will interpolate it correctly. For any other case, it is possible to combine a translation with a rotation by Animating Subgroups and Subcomponents.

A scaling will interpolate the size of objects, for any positive or negative scale factor, for any component axis (red, green, or blue). Version 2.0 fixed the bug involving negative scale factors.

You can translate and scale an object at the same time. Keyframe Animation will always interpolate this correctly.

A scaling and a rotation can usually be combined. If the point scaled about lies on the axis of rotation, then Keyframe Animation will interpolate it correctly. If they are different, the interpolation will use a new fixed point to both rotate and scale about -- which may look just as good. It is possible to scale about one point, while rotating about a different point, by Animating Subgroups and Subcomponents.

new iconNew in version 2.0: Reflections
If you flip an object along its red, green, or blue axis (right-click > Flip Along), that reflects it. Version 2.0 interpolates a Reflection by moving every point along a line that passes through a "mirror plane" in the middle to a point an equal distance on the other side -- reflecting the object in the process.
new iconNew in version 2.0: Inversions
If you flip an object along all three axes, that inverts it. It amounts to a reflection through the center point. Version 2.0 interpolates an Inversion by moving every point along a line that passes through the center to a point an equal distance on the other side -- inverting the object in the process.
tip iconTip: Reflections and Rotations
If you flip an object along two axes, that is actually the same operation as rotating it 180 degrees, so it is interpolated as an ordinary rotation.

Step 7 - Watch the Animation

The Play Button Play Button on the toolbar toggles Object Animation on or off. When toggled on, objects will automatically move to their recorded positions during each scene transition.

When the Play button is toggled off, the objects won't move. Object animation is initially turned off when SketchUp first opens.

You can test out the animation by selecting one scene at a time to initiate each scene transition. Or run a slideshow of the whole animation (View > Animation > Play).

tip iconTip: What to do if objects don't move.
If your objects are not moving, here are some steps to diagnose the cause.
  • The most likely reason is that the object animation is turned off. It is turned off by default when SketchUp opens. Click the Play Button to turn object animation on.
  • The objects aren't suppose to move when you toggle the Play button on. That only enables movement. The objects should then move when you select a scene, or run the slideshow animation.
  • Make sure it is a group or component. Loose Geometry can not be recorded or animated. Use the Entity Info window to check the type (right-click > Entity Info).
  • An object will not move if there is no position data saved on the scene for it. Click the Select Button to see which objects have positon data saved on the current scene.
  • If the object still doesn't move, maybe the position saved is the same as where it's at already. Try moving it somewhere else, and then select the scene tab. It should move back.

If an object is open for editing, the Object Animation will still proceed, but it is restricted to the moving objects that are contained in the active context.

Step 8 - Set Scene Transition and Delay Times

Click the Time Settings Button to display the Scene Time Settings window. This interface allows you to set the transition time and delay time for each scene. The time is rounded to half-second intervals.

The transition time is the number of seconds it takes for the animated objects to move to their recorded positions. It is also the time it takes for scene properties -- like camera location, or shadow settings -- to transition to the value saved with the scene. A negative value will use the default transition time.

The delay time is the number of seconds the animation will wait before beginning the transition to the next scene. A negative value will use the default delay time.

All settings are saved as soon as the textbox loses focus. A bell will ring to indicate the value has changed.

Animating Subgroups and Subcomponents

Keyframe Animation allows you to animate subgroups (or subcomponents) to any depth. Subgroups (subcomponents) move relative to their parent. They inherit their parent's motion, and then apply their own movement relative to it. This allows you to compose translations, rotations, and scaling operations, in order to create more complex types of motion.

To record a subgroup (subcomponent), select it first, then click the Record button. Usually, the easiest way to select a nested object is with Outliner. The other way is to open the objects that contain it by successively double-clicking on them, until you can select the nested object.

Exporting the Animation

Once your animation is set up, you can export it to a standard video, custom video, or an image sequence. SketchUp has a utility to export animations, but it only exports the the animation of scene properties, and ignores the object animation. Now, however, Keyframe Animation has the ability to export both the scene property animation and the object animation, directly from your keyframe model. This is completely new in version 2.0. You no longer have to create the tweens to export the object animation. This new approach is fast, simple, and far more efficient than creating the resource intensive tweens.

new iconNew in version 2.0
Now Keyframe Animation plays nice with all the scene properties. Combine your Keyframe object animation with SketchUp's built-in animation of Camera Location, Style and Fog, Shadow Settings, Section Planes, Layer Visibility, and Hidden Geometry, and export it all to a video, or image sequence.

Exporting a Standard Video   (PC only)

Click the Export Video Button to export the animation as a video with standard settings. (Currently this only supported on the PC, not the Mac.)

The menu access is at Export Animation > Standard Video...

You can quickly choose from over a dozen common frame sizes having a 4:3 or 16:9 aspect ratio.

There are several video codecs and formats that are new in version 2.0.

Exporting a Custom Video   (PC only)

Access the menu item Export Animation > Custom Video... to export the animation as a video with custom settings. (Currently this only supported on the PC, not the Mac.)

The Frame Rate can go from 1 to 60 frames per second.

The Frame Size can go from 8x8 to 3840x2160 pixels.

The Video Encoding-Format options are the same as the Standard Video export.

Exporting an Image Sequence   (PC and Mac)

Access the menu item Export Animation > Image Sequence... to export the animation as a sequence of image files.

The Frame Rate can go from 1 to 60 frames per second.

The Frame Size can go from 8x8 to 3840x2160 pixels.

The Image Format has a drop-down list to choose from JPG, PNG, TIF, or BMP.

The Background is always opaque for .jpg, .tif, and .bmp image types. However, if you are exporting .png type images, then the background can be either opaque or transparent.

The Export Process

There is a new Progress Bar in version 2.0. It displays the time elapsed and the estimated time remaining, and generally makes the export process more user friendly.

The export process is also much more controlled. SketchUp no longer hangs forever while you watch the spinning ball, as was the case when generating the tweens. Click the Stop Export button to interrupt the frame processing at any time. You can resume it later, or stop and quit.

If you quit, the frames that have already been generated are saved in a folder. The next time you export the animation, with the same settings, you can reuse those frames.

You can even export half the frames one day, quit, close SketchUp, reopen it some other day, and pick up where you left off.

The frame folder is given a name based on the model name, the frame rate, the frame size, and the type of images exported. The folder is located in the same directory as the SketchUp model.

A typical frame folder name is, myModel - 24fps 640x360 jpg.

If you are exporting an image sequence, once the frame export is complete, that is the end of the process. Close the Progress Bar window.

If you are exporting a video, there will be an Export Video button. Click it to run a program that compresses the frames into a video with the encoding and format that were selected.

tip iconTip: Exporting videos with different formats
You only need to generate all the frames once for a particular frame size and frame rate. After that, you can reuse the same frames to export videos with different formats and encodings. For example, H.264 codec (.mp4), VP8 or VP9 (.webm), Animated GIF (.gif), Lossless or Uncompressed (.avi), etc.

The video file is given a name based on the model name, the frame rate, and the frame size. It is located in the same folder as the SketchUp model.

A typical video file name is, myModel - 24fps 640x360.mp4.

Once the video is created, the Progress Bar window displays the name of the video file and the frames folder.

If you don't need the frames for anything else, you can delete them and the folder by clicking the Delete Frames button.

And that's it; the animation is exported. Much more simple than the old way of generating all those tweens. The animations can probably be much longer with this new approach too.

Caveat

Exporting the animation to a video is not yet supported on the Mac. Currently, the only way to export the animation on the Mac is as an image sequence. Of course, if you are on a Mac, you can always use Quicktime, and capture a video that way.

Backward Compatibility

menu

What is going on under the hood in version 2.0 is so different that your version 1.x animation will not run. Basically, if you open a model with version 1.x position data, all of the commands on the toolbar and menu will be disabled.

However, version 2.0.5 has a utility that will convert a 1.x animation to the format used in Keyframe Animation 2. You can access this utility from the menu at Keyframe Animation > Convert v1 to v2. It will be practically the only thing on the menu that is not disabled.

The Keyframe 2 compatible animation is created in a new model. You can save it with any name you want. The original model is NOT modified.

Once the new model is open, your old animation will work in Keyframe Animation 2.0, and all the toolbar buttons and menu items will be enabled normally. This feature does require SketchUp 2014 or newer.